gitlab-ci: Use cabal-install 2.4 on Darwin

Authored by bgamari on Dec 16 2018, 7:32 PM.