Hadrian: programs need registered ghc-pkg libraries

Authored by DavidEichmann on Apr 30 2019, 6:02 AM.

Description

Hadrian: programs need registered ghc-pkg libraries

In Hadrian, building programs (e.g. ghc or haddock) requires libraries located in the ghc-pkg package database i.e.

_build/stage1/lib/x86_64-linux-ghc-8.9.0.20190430/libHSdeepseq-1.4.4.0-ghc8.9.0.20190430.so

Add the corresponding needs for these library files and the subsequent rules.

Details

Committed
Marge Bot <ben+marge-bot@smart-cactus.org>May 10 2019, 3:38 PM
Parents
rGHCc7913f71bc8e: Fix bugs and documentation for #13456
Branches
Unknown
Tags
Unknown
Marge Bot <ben+marge-bot@smart-cactus.org> committed rGHCbfcd986dc424: Hadrian: programs need registered ghc-pkg libraries (authored by DavidEichmann).May 10 2019, 3:38 PM