Testsuite: refactoring only
- Rename platform_wordsize_qualify to find_expected_file, and make it return a filename instead of an (absolute) filepath.
- Replace most usages of qualify by in_testdir. Others usage sites will be deleted in a later commit.
These changes will be useful in a later commit, when we'll distinguish
between files in the source directory and those in a (newly created)
Reviewed by: austin, bgamari
Differential Revision: https://phabricator.haskell.org/D1186