I like working on GHC. 'tis all I have to say.
- User Since
- Jul 20 2014, 6:05 AM (140 w, 9 h)
- Bump array submodule
Fri, Mar 24
Thu, Mar 23
Sounds good to me.
Wed, Mar 22
Tue, Mar 21
Requesting changes on account of testsuite failures.
Sun, Mar 19
Bumping out of review queue due to apparent nofib regressions. Let me know when you would like a review, @nomeata!
Sat, Mar 18
Thanks for the refactoring! Looks good to me except for the validation issues.
Frankly, this check is cheap enough that I wonder whether it might be better to simply always perform it.
Thu, Mar 16
Alright, this seems reasonable enough although we should do the same for the other architectures soon.
I think we should reassess the point of this check and name it more appropriately. It looks like we primarily use FP_LEADING_UNDERSCORE to form symbols names in the RTS. In light of this, I would have thought that this should be named FP_LEADING_UNDERSCORE_TARGET.
Indeed I remember this being necessary. I don't know what to do about this. I'm really not excited about this approach. For one, it introduces a git dependency into the build system. Secondly, it pulls down untrusted code from the Internet (I would at very least freeze us at a particular commit so we know what we are getting).
I don't believe this patch changes this. You can use GHC against Debian's clang, just as you can use it against Debian's llc and opt.
Wed, Mar 15
Tue, Mar 14
Indeed it seems I misread the ticket. Ignore my previous comment.