Allow containers-0.6, QuickCheck-2.12 in Hadrian
ClosedPublic

Authored by RyanGlScott on Nov 28 2018, 12:35 PM.

Details

Summary

Currently, Hadrian has restrictive upper bounds on
containers and QuickCheck that prevents it from building with
the latest versions of each respective library (0.6.0.1 and
2.12.6.1). There doesn't appear to be any good reason to do so,
since Hadrian builds fine with them, so let's bump the upper version
bounds accordingly.

Test Plan

./build/hadrian.sh

Diff Detail

Repository
rGHC Glasgow Haskell Compiler
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
RyanGlScott created this revision.Nov 28 2018, 12:35 PM
snowleopard accepted this revision.Nov 28 2018, 12:49 PM

Thanks! Sure, let's bump the bounds.

This revision is now accepted and ready to land.Nov 28 2018, 12:49 PM
This revision was automatically updated to reflect the committed changes.