Bump Cabal to 2.5.0.0 and fix build errors.
AbandonedPublic

Authored by DavidEichmann on Nov 12 2018, 12:27 PM.