I tend to think that having newtypes is generally better than type synonyms (modulo boilerplate). Also it's for congruence with UniqSet. But a short comment doesn't hurt, I guess.
This is how it's done for UniqSet. I'm just following the pattern here. It's probably due to some API stability guarantee, who knows.
Yes, I'm planning to do a second diff with that change that would also change the implementation of pprUniqSet in the same way.