Respect naming conventions in module RnUnbound.hs in fix for #15611
ClosedPublic

Authored by RolandSenn on Nov 7 2018, 2:35 PM.

Details

Summary

The patch Phab:D5284​ didn't respect the local naming conventions in module ​compiler/rename/RnUnbound.hs:

  • Top level functions names are written in camelCase.
  • Local function names in where clauses are written as names_with_underscores.

This patch restores these conventions.

Test Plan

make test TESTS="T15611a T15611b"

Diff Detail

Repository
rGHC Glasgow Haskell Compiler
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
RolandSenn created this revision.Nov 7 2018, 2:35 PM
RolandSenn edited the summary of this revision. (Show Details)Nov 7 2018, 2:40 PM
mpickering requested changes to this revision.Nov 8 2018, 3:35 PM

Two comments.

compiler/rename/RnUnbound.hs
241

Please remove this fromJust and replace it with name which is bound above.

344–346

This note should be called something human understandable rather than the name of the function.

This revision now requires changes to proceed.Nov 8 2018, 3:35 PM
RolandSenn updated this revision to Diff 18628.Nov 9 2018, 2:06 AM
  • Changes requested by code review (Trac #15611.Phab:5308)
RolandSenn marked 2 inline comments as done.Nov 9 2018, 2:10 AM

Thanks for the review.

mpickering accepted this revision.Nov 9 2018, 2:37 AM

Thanks!

This revision is now accepted and ready to land.Nov 9 2018, 2:37 AM
This revision was automatically updated to reflect the committed changes.